Outbound message failures
Incident Report for Avochato
Postmortem

What Happened

A brief outage with Twilio’s REST API caused outbound SMS and WhatsApp messages to fail to send. Also, some other actions, including syncing Use-Cases to inboxes, would to fail intermittently and need to be re-attempted. Avochato partners with Twilio to send and receive calls and text messages for some customers. For more information on this particular incident, please see https://status.twilio.com/

Impact

Some customers may have seen a specific 20503 error code when sending an outbound message via Avochato. These specific outbound failed messages were not automatically re-tried.
Avochato inboxes continued to receive incoming messages during the impact period (appx between 5:30-6:30 PST on 8/18/23), and outbound messages continued to deliver as intended as soon as the issue was resolved.

Next steps

Our team will continue evaluating the resiliency of the inbox in case of temporary outages, as well as mechanisms to retry sending these types of failed messages. Meanwhile, customers leveraging other carrier partners, as well as Avochato live chat, were unaffected.

Thank you to the Twilio team for communicating status updates for this issue.

To our customers, we apologize for any inconvenience during the impact period, and thank you for using Avochato.

Posted Aug 18, 2023 - 10:59 PDT

Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 10:45 PDT
Update
We are observing significantly reduced errors connecting to our carrier partner but are awaiting confirmation that the incident has been resolved.
Posted Aug 17, 2023 - 19:03 PDT
Monitoring
Outbound messages for certain Avochato phone numbers are still experiencing issues sending outbound texts due to a network outage with our carrier partners.
Posted Aug 17, 2023 - 18:40 PDT
Investigating
We are investigating an issue impacting outbound message delivery failures on the carrier network.
Posted Aug 17, 2023 - 18:08 PDT
This incident affected: avochato.com, API, and Mobile.