The issue was resolved at 10:40am PT. Avochato continues to monitor and investigate the root case for the latency.
Posted Apr 25, 2025 - 12:33 PDT
Monitoring
Avochato is now monitoring the improvements across impacted inboxes with latency issues, which began 9:30am and resolved by 10:40am PT. Cloud provider resources are still under investigation but all impacted customers should now see normal inbox load times.
Posted Apr 25, 2025 - 11:21 PDT
Update
Currently seeing improvements to load speeds, however the team is continuing to monitor and work with our cloud provider as the impacted servers may still be impacting certain organizations and inboxes.
Posted Apr 25, 2025 - 10:32 PDT
Investigating
Avochato is investigating an issue with the AWS cloud provider, which may lead to latency on inbox loading. Please stay tuned for updates as the team resolves this issue asap.