Issues with Amazon Web Services

Incident Report for Avochato

Monitoring

Our service provider Amazon Web Services has not yet identified the root of the issues on Friday. However, the Avochato team is continuing with the investigation while having performed several actions to remediate the latency issues. As of 10:55am PST on Monday June 9, latency improved for those organizations experiencing issues when refreshing inboxes. Avochato's team switched to new server instances on Monday, and will continue Tuesday with a rollout of a permanent solution.
Posted Jun 10, 2025 - 08:05 PDT

Update

The team is continuing to investigate this issue while working on options with Amazon Web Services.

In the meantime, we recommend not refreshing an inbox. Once the inbox is loaded, messages will be received instantly and can be responded to in real-time. Refreshing the inbox may lead to longer delays.
Posted Jun 09, 2025 - 10:11 PDT

Investigating

Periodic latency has been observed starting at 8am PST. This may lead to longer than expected load times in inboxes across different organizations. Our team has been investigating the root cause with Amazon Web Services and will report back with findings.
Posted Jun 09, 2025 - 09:18 PDT
This incident affects: avochato.com and Mobile.