Slow page load times
Incident Report for Avochato
Postmortem

What Happened

A sudden escalation in CPU in our production database cloud database provider led to a period of longer than normal load times. While our platform was under high load for Cyber Monday, our investigation leads us to believe this was a hardware-related failure and our operations team responded accordingly.

Additionally, the period of slow response times led to our Slack application automatically turning off as per Slack’s platform policy. Engineers manually turned the app back on numerous times, but unfortunately some messages sent via Slack threads were unable to be delivered during the windows when the Slack app was disabled.

Resolution

Data was not lost as we were able to fail over to a read replica database.

We have upgraded database hardware to move away from potentially degraded hardware and performed routine system maintenance.

Posted Dec 01, 2020 - 08:03 PST

Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 16:04 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 30, 2020 - 13:14 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2020 - 12:06 PST
Update
We are continuing to investigate this issue.
Posted Nov 30, 2020 - 11:50 PST
Update
We are continuing to investigate this issue.
Posted Nov 30, 2020 - 10:25 PST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2020 - 10:03 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2020 - 09:36 PST
Investigating
We are currently investigating this issue.
Posted Nov 30, 2020 - 08:00 PST
This incident affected: avochato.com, API, and Mobile.