Login issues on v2.16 and v2.17 of Avochato for iOS
Incident Report for Avochato
Postmortem

What Happened

An update to how we handle state did not properly handle sessions generated in older versions of the app for previously logged in users. This caused the login screen of the iOS app to get in a state where it could not log an older or invalid session out and also could not proceed to the login screen for specific users upgrading from older versions of Avochato.

Resolution

We’ve patched the specific iOS component that handles state when upgrading versions and it should do a better job of cleaning up after older versions of Avochato whenever the app is upgraded or uninstalled and reinstalled. No further action is necessary at this time.

Posted Aug 04, 2022 - 10:01 PDT

Resolved
This issue is resolved in our most recent version of Avochato for iOS, 2.19, which is live in the AppStore.
Posted Aug 04, 2022 - 09:57 PDT
Monitoring
Version 2.18 of Avochato for iOS is now available. We are monitoring progress for users who were unable to log in using the latest version. Older versions of the iOS app, Avochato for Android, and our desktop and mobile web experiences have been unaffected during this period.
Posted Aug 03, 2022 - 12:57 PDT
Investigating
We are investigating an issue causing some users to get stuck at the loading screen on our most recent version of the Avochato for iOS app.
Posted Aug 02, 2022 - 14:01 PDT
This incident affected: Mobile.