East Coast platform latency
Incident Report for Avochato
Postmortem

What happened

Our East Coast cloud infrastructure was routing requests to West Coast databases, sometimes multiple trips for a single request. This caused delays for customers whose DNS were automatically routed to the East Coast, as well as network requests from API servers with an East Coast region.

Messages and application load times were delayed for customers closer to the East Coast region than the West Coast.

Resolution

We altered the threshold for sending traffic to the East Coast data center.

We have rolled back networking changes to East Coast infrastructure and systems have returned to normal

Posted Nov 25, 2020 - 12:27 PST

Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 15:21 PST
Monitoring
We have made an infrastructure update which appears to have resolved latency impacting East Coast customers. We will continue to monitor page load times for impacted routes.
Posted Nov 23, 2020 - 10:01 PST
Identified
We are aware of an infrastructure issue that is causing slower than average page times for US East Coast users.

We are working on a resolution.
Posted Nov 23, 2020 - 09:20 PST
This incident affected: avochato.com, API, and Mobile.